Banners not forwarding

This is the place to post questions and comments about the FlexBanner component
Post Reply
Troels_E
Posts: 9
Joined: Sun Jan 24, 2016 9:27 pm

Banners not forwarding

Post by Troels_E » Sun Aug 28, 2016 3:40 pm

My site www.stenmessen-kbh.dk/dk has some sponsor links in left side and while they have worked fine so far they are no longer forwarding correct.
fex. I have a link http://www.ikecho.dk that now links to: http://www.stenmessen-kbh.dk/dk/compone ... click&id=4

I have not made any changes backend relating to Flexbanners but naturally Joomla and other plugins are kept up-to-date and server is now on PHP7.

Any clues as to what is wrong with my site?

Andrew998
Posts: 1350
Joined: Wed Jan 07, 2009 10:43 am

Re: Banners not forwarding

Post by Andrew998 » Sun Aug 28, 2016 3:56 pm

And what happens when you click that link? Remember, it doesn't show the final link in the browser.
Andrew998
Developer

Troels_E
Posts: 9
Joined: Sun Jan 24, 2016 9:27 pm

Re: Banners not forwarding

Post by Troels_E » Mon Aug 29, 2016 9:39 pm

I'm not sure what you mean. If I click what link?

I was just going to try and setup a new link in a new location.
Going to an existing location gives this warning.
Warning: Declaration of FlexbannersModelLocation::prepareTable(&$table) should be compatible with JModelAdmin::prepareTable($table) in /var/www/stenmessen-kbh.dk/public_html/administrator/components/com_flexbanners/models/location.php on line 12

Going to manage link and clicking an existing link gives the same warning.

Any help appreciated.

Andrew998
Posts: 1350
Joined: Wed Jan 07, 2009 10:43 am

Re: Banners not forwarding

Post by Andrew998 » Tue Aug 30, 2016 10:48 am

This is not something we see in testing. Can you confirm which version of Joomla and FlexBanner you are using please.

Thanks
Andrew998
Developer

Troels_E
Posts: 9
Joined: Sun Jan 24, 2016 9:27 pm

Re: Banners not forwarding

Post by Troels_E » Tue Aug 30, 2016 11:55 am

J3.6.2
Flexbanners 4.1.00

I can provide you with back-end access and will pay for your time to get it fixed.
email me: kontakt (at) stenogfritid.dk

Andrew998
Posts: 1350
Joined: Wed Jan 07, 2009 10:43 am

Re: Banners not forwarding

Post by Andrew998 » Tue Aug 30, 2016 3:29 pm

I've turned off warnings in configuration which has dealt with the warning issue and the links seem to work fine. Has that overcome your problem?

I'll do an update that fixes the warning at some point.
Andrew998
Developer

Troels_E
Posts: 9
Joined: Sun Jan 24, 2016 9:27 pm

Re: Banners not forwarding

Post by Troels_E » Wed Aug 31, 2016 11:05 am

No unfortunately none of the links is working here.

Clicking the link still takes me to http://www.stenmessen-kbh.dk/dk/compone ... click&id=4
other link to same URL with different id=X

Andrew998
Posts: 1350
Joined: Wed Jan 07, 2009 10:43 am

Re: Banners not forwarding

Post by Andrew998 » Wed Aug 31, 2016 1:39 pm

Something on your site is interfering with the URL rewriting for SEF URLs. Do you have anything unusual in your .htaccess file or unusual sef type components?
Andrew998
Developer

Troels_E
Posts: 9
Joined: Sun Jan 24, 2016 9:27 pm

Re: Banners not forwarding

Post by Troels_E » Wed Aug 31, 2016 7:27 pm

Thanks will look into that, we do have some SEF plugin running.
It's called Easy frontend SEO and obviously causes this.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest