Error message on front end with FB enabled

This is the place to post questions and comments about the FlexBanner component
Post Reply
piperdesigns
Posts: 5
Joined: Sat Feb 21, 2009 5:59 am

Error message on front end with FB enabled

Post by piperdesigns » Sat Feb 21, 2009 6:06 am

I just installed FlexBanner and enabled it. I'm now getting the following message when I try to view the front end on my site:

Fatal error: require_once() [function.require]: Failed opening required '' (include_path='.:/usr/lib/php5') in /homepages/27/d255894770/htdocs/HawaiiAEC/modules/mod_flexbanner/mod_flexbanner.php on line 18

Does anyone know what is causing this.

Thanks, Pete

Andrew998
Posts: 1384
Joined: Wed Jan 07, 2009 10:43 am

Re: Error message on front end with FB enabled

Post by Andrew998 » Sat Feb 21, 2009 12:33 pm

Sorry, there's an error in 1.5.11. Can you try 1.5.12 please.
Andrew998
Developer

piperdesigns
Posts: 5
Joined: Sat Feb 21, 2009 5:59 am

Re: Error message on front end with FB enabled

Post by piperdesigns » Sat Feb 21, 2009 4:15 pm

Hi Andrew,

Thanks for your reply, unfortunatly I'm still getting the same error with 1.5.12

Andrew998
Posts: 1384
Joined: Wed Jan 07, 2009 10:43 am

Re: Error message on front end with FB enabled

Post by Andrew998 » Sat Feb 21, 2009 4:28 pm

I think it's likely to be a problem with your Joomla installation. Your first step should be to overwrite all the Joomla files and see if you still have a problem.
Andrew998
Developer

Andrew998
Posts: 1384
Joined: Wed Jan 07, 2009 10:43 am

Re: Error message on front end with FB enabled

Post by Andrew998 » Sat Feb 21, 2009 4:36 pm

You have installed the component, not just the module I take it?
Andrew998
Developer

piperdesigns
Posts: 5
Joined: Sat Feb 21, 2009 5:59 am

Re: Error message on front end with FB enabled

Post by piperdesigns » Sat Feb 21, 2009 7:04 pm

OK, that's the problem, I didn't understand that I needed to install both. No error now!!

I was mistakenly trying to use the standard Joomla banner component and thought FB was working with that but now I see the FB is a separate component.

I'm trying to create a banner to display in the header area on my site with FB. I have created a banner, client, link and location but I can't seem to figure out how to get the banner into my header. Is there any documentation on how to use FB?

Andrew998
Posts: 1384
Joined: Wed Jan 07, 2009 10:43 am

Re: Error message on front end with FB enabled

Post by Andrew998 » Sat Feb 21, 2009 7:11 pm

There's a brief guide here: http://www.inchhosting.co.uk/joomla/fle ... guide.html

Most important thing is to get the numeric location ID right in the module.
Andrew998
Developer

piperdesigns
Posts: 5
Joined: Sat Feb 21, 2009 5:59 am

Re: Error message on front end with FB enabled

Post by piperdesigns » Thu Feb 26, 2009 3:44 am

Hi Andrew,

I've read your documentation and I have a question about item 4.
Once these options are defined you can use the Manage Banners link to set up your banner. This draws together all the other information to define the banner, its image, its owning client and the link. It also allows you to define where and when the banner should appear. If you put more than one banner in a location the module will show them at random on each page refesh.
I don't know how to define the location. I want my banner to show up in the left column so I entered 'left' in the location box but that doesn't work so I'm guessing I need to enter some kind of code there.

Thanks, Pete

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests