JInstaller: :Install: Error SQL DB function failed

This is the place to post questions and comments about the FlexBanner component
Post Reply
user_francesco
Posts: 3
Joined: Tue Nov 24, 2015 5:55 pm

JInstaller: :Install: Error SQL DB function failed

Post by user_francesco » Tue Nov 24, 2015 6:36 pm

Hi,
(Joomla 2.5.27 - com_flexbanners_4.0.29.zip)
I tried to install the extension on 3 webjoomla sites but I had a lot of errors, starting with:
JInstaller: :Install: Error SQL DB function failed with error number 1146
Table 'Sql123456_5.hx76f_content_types' doesn't exist
and
Component Install: SQL error file DB function failed with error number 1146
I read in the forum that other people had a similar problems with the installation, but I have not found answers that helped me to solve this.

Could you please help me?
Thank you, my best regards
Francesco

Andrew998
Posts: 1400
Joined: Wed Jan 07, 2009 10:43 am

Re: JInstaller: :Install: Error SQL DB function failed

Post by Andrew998 » Tue Nov 24, 2015 6:54 pm

You can use the attached version to update.

But please update Joomla to 2.5.28, the version you are using is not secure.

Update
Andrew998
Developer

user_francesco
Posts: 3
Joined: Tue Nov 24, 2015 5:55 pm

Re: JInstaller: :Install: Error SQL DB function failed

Post by user_francesco » Tue Nov 24, 2015 8:20 pm

Thank you for you answer.
I have updated J 2.5.28 and then I used the update you posted to install FlexBanner but I have the same problem
JInstaller: :Install: Errore SQL DB function fallita con errore numero 1146
It seems some tables don't exist. Might be a permission problem?

Thank you
Best regards
Francesco

Andrew998
Posts: 1400
Joined: Wed Jan 07, 2009 10:43 am

Re: JInstaller: :Install: Error SQL DB function failed

Post by Andrew998 » Tue Nov 24, 2015 8:36 pm

Are you installing FlexBanner rather than updating? If so, install FlexBanner 4.0.20 first and then update.
Andrew998
Developer

user_francesco
Posts: 3
Joined: Tue Nov 24, 2015 5:55 pm

Re: JInstaller: :Install: Error SQL DB function failed

Post by user_francesco » Tue Nov 24, 2015 10:01 pm

Ok, now there are no errors.

Thanks a lot
Francesco

Post Reply