Live update storage error

This is the place to post questions and comments about the FlexBanner component
neerajjoshi786
Posts: 1
Joined: Sat Dec 28, 2013 7:36 am

Live update storage error

Post by neerajjoshi786 » Sat Dec 28, 2013 7:51 am

Hello

I am using joomla 2.5.9 on my localhost and installed flex banner version 4.0.3 .

It is installed successfully but when I run click on flxe banner in admin it gives error

Warning: LiveUpdateStorage::require_once(__DIR__/component.php) [liveupdatestorage.require-once]: failed to open stream: No such file or directory in D:\xampp\htdocs\rd\j_2.5\administrator\components\com_flexbanners\liveupdate\classes\storage\storage.php on line 46

Fatal error: LiveUpdateStorage::require_once() [function.require]: Failed opening required '__DIR__/component.php' (include_path='.;D:\xampp\php\pear\') in D:\xampp\htdocs\rd\j_2.5\administrator\components\com_flexbanners\liveupdate\classes\storage\storage.php on line 46


The other sections Categories, Links are working fine
Attachments
error.png
Please check this
error.png (102.21 KiB) Viewed 2982 times

Andrew998
Posts: 1400
Joined: Wed Jan 07, 2009 10:43 am

Re: Live update storage error

Post by Andrew998 » Sat Dec 28, 2013 11:15 am

Can you please start by updating Joomla to the latest version (2.5.17), it isn't safe to remain on 2.5.9. If the problem continues after that let me know and I'll take a look.
Andrew998
Developer

Domazet
Posts: 1
Joined: Sat Jan 04, 2014 11:26 am

Re: Live update storage error

Post by Domazet » Sat Jan 04, 2014 11:29 am

Flexbanner 4.0.4, no works with joomla 2.5.9 or 2.5.17

Andrew998
Posts: 1400
Joined: Wed Jan 07, 2009 10:43 am

Re: Live update storage error

Post by Andrew998 » Sat Jan 04, 2014 11:54 am

I suspect it is a problem with your server. The error is being generated in the live update component which is not supported by us. It is supplied by Akeeba.
Andrew998
Developer

ndarras
Posts: 4
Joined: Sun Feb 09, 2014 11:50 am

Re: Live update storage error

Post by ndarras » Sun Feb 09, 2014 11:55 am

Hi I am having the same problem

Warning: require_once(__DIR__/component.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/vhosts/v-v-v.gr/httpdocs/site/my/administrator/components/com_flexbanners/liveupdate/classes/storage/storage.php on line 46

Fatal error: require_once() [function.require]: Failed opening required '__DIR__/component.php' (include_path='.:') in /var/www/vhosts/v-v-v.gr/httpdocs/site/my/administrator/components/com_flexbanners/liveupdate/classes/storage/storage.php on line 46

Are there any solutions ...

Andrew998
Posts: 1400
Joined: Wed Jan 07, 2009 10:43 am

Re: Live update storage error

Post by Andrew998 » Sun Feb 09, 2014 12:04 pm

This is not a problem with FlexBanner. To be honest, it looks like your installation of FlexBanner didn't complete correctly. I would download the latest version (4.0.8) and try again.
Andrew998
Developer

ndarras
Posts: 4
Joined: Sun Feb 09, 2014 11:50 am

Re: Live update storage error

Post by ndarras » Sun Feb 09, 2014 1:36 pm

I re-installed the latest version com_flexbanners_4.0.8.zip.

I did not get any error messages and the installation ended with the following message

-----------------
Successfully installed FlexBanner Component and Module

FlexBanner is a powerful banner management system that allows you to choose which articles or categories a banner appears on. It supports the use of Flash banners and reports clicks.
-------------------

Is there a parameter that I should check in my server to overcome the problem?

By the way, all other forms (Categories, Clients, Links etc .) work fine except the FlexBanners link.

Andrew998
Posts: 1400
Joined: Wed Jan 07, 2009 10:43 am

Re: Live update storage error

Post by Andrew998 » Sun Feb 09, 2014 4:05 pm

Have you actually looked at the server to check whether that file is there?
Andrew998
Developer

ndarras
Posts: 4
Joined: Sun Feb 09, 2014 11:50 am

Re: Live update storage error

Post by ndarras » Sun Feb 09, 2014 6:59 pm

Yes I did. The file is there.

I also commented the error line and then it presented another error in a later line.

I also checked the folder and file permissions.

The folder has 755 and the file 644.

Any other ideas?

Andrew998
Posts: 1400
Joined: Wed Jan 07, 2009 10:43 am

Re: Live update storage error

Post by Andrew998 » Sun Feb 09, 2014 7:26 pm

A quick Google shows it to be a php problem. You need to update to php 5.3 to overcome this error (or replace __DIR__ with dirname(__FILE__) in the file).
Andrew998
Developer

Post Reply