Problem with the update to version 4.0.12

This is the place to post questions and comments about the FlexBanner component
riga75
Posts: 3
Joined: Mon Mar 10, 2014 7:54 am

Problem with the update to version 4.0.12

Post by riga75 » Mon Mar 10, 2014 7:58 am

I have the verisone 4.0.0 and would like to upgrade to 4.0.12
I tried both the update panel of the component by downloading the full package but I always get the same error:


JInstaller: :Install: Errore SQL DB function fallita con errore numero 1060
Duplicate column name 'modified' SQL=ALTER TABLE `l2e3g_flexbanners` ADD `modified` datetime NOT NULL default '0000-00-00 00:00:00';
SQL =

ALTER TABLE `#__flexbanners` ADD `modified` datetime NOT NULL default '0000-00-00 00:00:00';

Aggiornamento componente: file errore SQL DB function fallita con errore numero 1060
Duplicate column name 'modified' SQL=ALTER TABLE `l2e3g_flexbanners` ADD `modified` datetime NOT NULL default '0000-00-00 00:00:00';
SQL =

ALTER TABLE `#__flexbanners` ADD `modified` datetime NOT NULL default '0000-00-00 00:00:00';


What should I do?
thanks a lot

stefano

Andrew998
Posts: 1400
Joined: Wed Jan 07, 2009 10:43 am

Re: Problem with the update to version 4.0.12

Post by Andrew998 » Mon Mar 10, 2014 5:27 pm

Please try the attached version.
Attachments
com_flexbanners_4.0.12update.zip
(288.48 KiB) Downloaded 142 times
Andrew998
Developer

riga75
Posts: 3
Joined: Mon Mar 10, 2014 7:54 am

Re: Problem with the update to version 4.0.12

Post by riga75 » Tue Mar 11, 2014 7:05 am

By admin has uploaded correctly but if I go in the front end does not load the site but I get this message (see screenshot)
[attachment=0]Schermata 2014-03-11 alle 08.07.36.png[/attachment]
stefano
Attachments
Schermata 2014-03-11 alle 08.07.36.png
Schermata 2014-03-11 alle 08.07.36.png (252.45 KiB) Viewed 2821 times

Andrew998
Posts: 1400
Joined: Wed Jan 07, 2009 10:43 am

Re: Problem with the update to version 4.0.12

Post by Andrew998 » Tue Mar 11, 2014 7:59 am

Can you check in the module that you have a position chosen.
Andrew998
Developer

riga75
Posts: 3
Joined: Mon Mar 10, 2014 7:54 am

Re: Problem with the update to version 4.0.12

Post by riga75 » Tue Mar 11, 2014 9:33 am

It is now placed in the position banner and sidebar - b
Now I disabled the module from the admin side and the site is loaded but obviously are not displayed

Andrew998
Posts: 1400
Joined: Wed Jan 07, 2009 10:43 am

Re: Problem with the update to version 4.0.12

Post by Andrew998 » Tue Mar 11, 2014 9:34 am

I'm happy to have a look if you send me details.
Andrew998
Developer

ebohatch
Posts: 9
Joined: Mon Nov 28, 2011 2:47 pm

Re: Problem with the update to version 4.0.12

Post by ebohatch » Wed Mar 12, 2014 1:07 pm

I have a problem with the update too. I don't get any errors but the existing banners where I have multiple versions no longer display at all.
If I re-install the version 4.03 then they all work correctly. It seems that it doesn't allow multiple banners in same module position.

Andrew998
Posts: 1400
Joined: Wed Jan 07, 2009 10:43 am

Re: Problem with the update to version 4.0.12

Post by Andrew998 » Wed Mar 12, 2014 1:08 pm

Have you chosen how many banners you want to display in the module?
Andrew998
Developer

ebohatch
Posts: 9
Joined: Mon Nov 28, 2011 2:47 pm

Re: Problem with the update to version 4.0.12

Post by ebohatch » Wed Mar 12, 2014 1:18 pm

Yes I have.

Andrew998
Posts: 1400
Joined: Wed Jan 07, 2009 10:43 am

Re: Problem with the update to version 4.0.12

Post by Andrew998 » Wed Mar 12, 2014 1:20 pm

Well the component is working fine in testing and with many other users so I suspect the problem is elsewhere. I'm happy to take a look if you want.
Andrew998
Developer

Post Reply