Update install problem with database

This is the place to post questions and comments about the FlexBanner component
Post Reply
7weight
Posts: 6
Joined: Thu Jul 07, 2011 6:50 pm

Update install problem with database

Post by 7weight » Tue May 27, 2014 8:56 pm

Good afternoon,
I've been a user and fan of Flexbanner for at least 4 years now and have had no issues with updates until lately. I have version 4.0.0 installed, and when I click to auto-upgrade the version to 4.0.17, I receive the following error messages:
===========================
JInstaller: :Install: Error SQL DB function failed with error number 1060
Duplicate column name 'modified' SQL=ALTER TABLE `b7w_flexbanners` ADD `modified` datetime NOT NULL default '0000-00-00 00:00:00';
SQL =
ALTER TABLE `#__flexbanners` ADD `modified` datetime NOT NULL default '0000-00-00 00:00:00';
Component Update: SQL error file DB function failed with error number 1060
Duplicate column name 'modified' SQL=ALTER TABLE `b7w_flexbanners` ADD `modified` datetime NOT NULL default '0000-00-00 00:00:00';
SQL =
ALTER TABLE `#__flexbanners` ADD `modified` datetime NOT NULL default '0000-00-00 00:00:00';
===========================

Now when I got into the Flexbanner component and try to create a new banner, I receive this message as well:
===========================
Unknown column 'linkname' in 'field list' SQL=SELECT linkid AS value, IF(LENGTH(linkname)>0, linkname, linkurl) AS text FROM b7w_flexbannerslink AS a ORDER BY a.linkname
===========================


Any help will be greatly appreciated. As always, thank you in advance,
Grant

7weight
Posts: 6
Joined: Thu Jul 07, 2011 6:50 pm

Re: Update install problem with database

Post by 7weight » Tue May 27, 2014 9:02 pm

A bit more information.
- I tried the database "fix" button on the Manage Extensions page, and this did not resolve the issue
- I am running Joomla 2.5.18 and will be upgrading to 3.x shortly, but I need the 2.5 version to work for a couple more months.
- I manually downloaded the latest version of Flexbanner and tried installing it via the Extensions Manager install page with the same results as the auto update option.

Andrew998
Posts: 1400
Joined: Wed Jan 07, 2009 10:43 am

Re: Update install problem with database

Post by Andrew998 » Wed May 28, 2014 11:21 am

Can you try the attached package please.

And please update from 2.5.18 to 2.5.20. It is not safe to run old versions of Joomla!
Attachments
com_flexbanners_4.0.17update.zip
(289.9 KiB) Downloaded 149 times
Andrew998
Developer

7weight
Posts: 6
Joined: Thu Jul 07, 2011 6:50 pm

Re: Update install problem with database

Post by 7weight » Wed May 28, 2014 11:41 am

That worked Andrew! Thank you so much. Two questions:
1) What is the difference between this package and the one available for download?
2) I checked Flexbanner after install, and all appears to be working - except for the client filter. When I select a client from the dropdown, the page refreshes, but it still shows all clients in the output. Also instead of "select client" or whatever is standard here in the dropdown field, it shows "COM_FLEXBANNER_SELECT_CLIENT" and appears to be missing a language file. Is this related to the client selection not working?

Thank you so much for the quick response and helping make this update work.

Andrew998
Posts: 1400
Joined: Wed Jan 07, 2009 10:43 am

Re: Update install problem with database

Post by Andrew998 » Wed May 28, 2014 11:44 am

The only difference is the MySql update files. I took out the updates that had already been done so that the new ones completed correctly. This problem arose when I combined the version 2 and 3 packages and ran into problems with different database versions.

I'll take a look at the client filter when I get a moment. The language field is not the cause. The filter does work correctly in Joomla 3 so I'm not going to prioritise it.
Andrew998
Developer

7weight
Posts: 6
Joined: Thu Jul 07, 2011 6:50 pm

Re: Update install problem with database

Post by 7weight » Wed May 28, 2014 11:57 am

Ok. Thank you for your help. I'll look for your response to the client filter issue.

Post Reply