Flexbanner ready for Joomla! 3.5.x AND PHP 7.x ?

This is the place to post questions and comments about the FlexBanner component
Ethlaegil
Posts: 5
Joined: Fri Mar 18, 2016 4:46 pm

Flexbanner ready for Joomla! 3.5.x AND PHP 7.x ?

Post by Ethlaegil » Fri Mar 18, 2016 4:49 pm

Hello,

is Flexbanner compatible with Joomla! 3.5.x run with PHP 7.x ?

Andrew998
Posts: 1342
Joined: Wed Jan 07, 2009 10:43 am

Re: Flexbanner ready for Joomla! 3.5.x AND PHP 7.x ?

Post by Andrew998 » Fri Mar 18, 2016 4:51 pm

I've tested it with Joomla! 3.5 but not with PHP7 yet.
Andrew998
Developer

Ethlaegil
Posts: 5
Joined: Fri Mar 18, 2016 4:46 pm

Re: Flexbanner ready for Joomla! 3.5.x AND PHP 7.x ?

Post by Ethlaegil » Fri Mar 18, 2016 4:58 pm

OK, so it works 100% with Joomla! 3.5.x?

It would be fine to know, if it works with PHP 7.x.x too! Because active support for PHP 5.6.x ends on 31.12.2016! http://php.net/supported-versions.php

Andrew998
Posts: 1342
Joined: Wed Jan 07, 2009 10:43 am

Re: Flexbanner ready for Joomla! 3.5.x AND PHP 7.x ?

Post by Andrew998 » Fri Mar 18, 2016 5:01 pm

Yes, it works fine on J3.5.

As for PHP, you'll find huge numbers aren't even on 5.6 yet (Plesk installations out of the box still offer 5.3!) and most hosts won't be offering PHP 7 for some time. I will test it but I don't believe it us urgent.
Andrew998
Developer

Ethlaegil
Posts: 5
Joined: Fri Mar 18, 2016 4:46 pm

Re: Flexbanner ready for Joomla! 3.5.x AND PHP 7.x ?

Post by Ethlaegil » Fri Mar 18, 2016 5:14 pm

OK, you think the end of PHP 5.6.x in about 9 months is not urgent to support PHP 7.x.x?

All responsible better Hostings have PHP 7.x.x already to choose! It is twice as fast as PHP 5.6.x with 50% less resource hunger!

I think it is very urgent to migrate Software as fast as possible to support PHP 7.x!

Andrew998
Posts: 1342
Joined: Wed Jan 07, 2009 10:43 am

Re: Flexbanner ready for Joomla! 3.5.x AND PHP 7.x ?

Post by Andrew998 » Fri Mar 18, 2016 5:16 pm

As I said, I will be testing it but your statement about responsible hosts is not accurate.
Andrew998
Developer

Ethlaegil
Posts: 5
Joined: Fri Mar 18, 2016 4:46 pm

Re: Flexbanner ready for Joomla! 3.5.x AND PHP 7.x ?

Post by Ethlaegil » Fri Mar 18, 2016 5:32 pm

OK, maybe you are right. But all major hosting companies in germany have PHP 7.x already. Like all-inkl.com, df.eu, 1und1, Strato, etc.

Andrew998
Posts: 1342
Joined: Wed Jan 07, 2009 10:43 am

Re: Flexbanner ready for Joomla! 3.5.x AND PHP 7.x ?

Post by Andrew998 » Fri Mar 18, 2016 5:56 pm

I've done a quick check with PHP 7 and there are some minor issues with FlexBanner. I will issue an update next week.
Andrew998
Developer

Ethlaegil
Posts: 5
Joined: Fri Mar 18, 2016 4:46 pm

Re: Flexbanner ready for Joomla! 3.5.x AND PHP 7.x ?

Post by Ethlaegil » Fri Mar 18, 2016 7:01 pm

Thank you, that are good news!

Troels_E
Posts: 9
Joined: Sun Jan 24, 2016 9:27 pm

Re: Flexbanner ready for Joomla! 3.5.x AND PHP 7.x ?

Post by Troels_E » Wed Mar 23, 2016 10:57 am

Was just checking up on this issue as we will be forced to use PHP 7 soon. Also it is not about when support ends but what PHP 7 has to offer which is a great boost for Joomla.

Looking forward to be PHP 7 compatible - Flexbanner is Afaik the last plugin I have not being fully compatible (as Fabrik was updated yesterday).
Just made a small donation and a review on JED.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests